NEW version 0.5.5 for Linux 64-bit

on

Download “Iris-0.5.5-Linux-64bit” Iris-0.5.5-Linux-64bit.tar.gz

There was a really stupid problem that I wanted to fix for maybe a month. Linux users who use 64-bit Ubuntu for example was getting error like this:
Screenshot from 2015-12-29 02:18:12

I’m pretty sure I fixed it with this build, but if not write to me again. 🙂

12 thoughts on “NEW version 0.5.5 for Linux 64-bit

  1. I got this problem,
    [email protected]:~/Downloads/Iris-0.5.5-Linux-64bit$ bash Iris.sh
    Iris.sh: line 13: 6849 Segmentation fault (core dumped) $dirname/$appname “$@”

    I am using ubuntu 15.10

    1. I would suggest to try to delete all files in the libs folder that doesn’t start with:
      libQt5

      In the end there should be only libQt5… libs in the folder and try again.

      Write me if this works. I have maybe shipped to many libs. This will drop the package size also 🙂

  2. Hello guys!

    When trying run using Iris.sh I receive following error:

    Iris: loadlocale.c:130: _nl_intern_locale_data: Assertion `cnt < (sizeof (_nl_value_type_LC_COLLATE) / sizeof (_nl_value_type_LC_COLLATE[0]))' failed.
    ./Iris.sh: line 13: 20404 Aborted (core dumped) $dirname/$appname "$@"

    But running from 'Iris' file works well 🙂

  3. Здрасти.Опитах се да инсталирам под Ubuntu 14.04,но ми вади същата грешка. Пробвах и с предишната версия, пак същият проблем.

    Hello. I tried to install under Ubuntu 14.04,but i recieved the same issue. I also tried with previous version (4.0) but it doesn’t work.

    Any suggestions?

    1. Iris.sh ли стартираш?

      bash Iris.sh
      също chmod 777 на Iris файла и на Iris.sh

      Пробвай да махнеш всички файлове от libs, които не започват с libQt.. или нещо подобно беше
      За тази версия на Ubuntu съм го направил не би трябвало да има проблем
      Пробвай също и с sudo да го стартираш

      1. Когато се опитах да махна всички и оставих само тези с libQt, получавам съобщение за грешка,че не намира друг файл.Качих го,после същата история с друг файл и така пак не стана. С chmod 777 на файла също, и дори с администраторски права опитах. xcm излиза отново. Странно

        1. Не е странно. Доста съм зле с Линукс-ите. Следващия build ще го направя статичен и дано да изчезнат тея грешки.
          Последно, което се сещам е
          първо
          sudo apt-get install libx11-dev
          и ако не стане
          sudo apt-get install libxcb1 libxcb1-dev libx11-xcb1 libx11-xcb-dev libxcb-keysyms1 libxcb-keysyms1-dev libxcb-image0 libxcb-image0-dev libxcb-shm0 libxcb-shm0-dev libxcb-icccm4 libxcb-icccm4-dev libxcb-sync0 libxcb-sync0-dev libxcb-xfixes0-dev libxrender-dev libxcb-shape0-dev

          Малко прекалено ама след това трябва да тръгне 😀

  4. WOW… Отново греда. Не можа да ми намери libxcb-sync0, за сметка като го махнах и оставих само libxcb-sync0-dev,се инсталира, но
    когато се опитах да подкарам отново sudo bash Iris.sh, отново същият проблем. Доста въртели :))

    1. Нещо не съм направил като хората. Трябва да си поиграя с различни линукси, за да го оправя. Следващия build ще го направя статичен и се надявам да се оправи всичко

Leave a Reply

Your email address will not be published. Required fields are marked *