Troubleshooting Cydia Impactor

Troubleshooting Cydia Impactor installation of Iris for iOS

To install Iris download the .ipa file from https://iristech.co/iris-ios/

You need to download this file from the PC or Mac, not from your iOS phone

New Guide for installation 2019.10

Old guide 2018

We have a full walkthrough of installing including the bugs and problems I went through when trying to do so:

You already have a current iOS development certificate error

App Specific Password required

This happens when Apple Developer certificate is expired and you need to contact the developer

Ignore this it’s already installed. In project settings, it should be with “”

You may get this error if you disable 2-factor authentication

We have a full walkthrough of installing including the bugs and problems I went through when trying to do so:

You already have a current iOS development certificate error

App Specific Password required

This happens when Apple Developer certificate is expired and you need to contact the developer

Ignore this it’s already installed. In project settings, it should be with “”

You may get this error if you disable 2-factor authentication

To better help you:

Take a screenshot and/or video of your iOS screen. Here is a guide: https://support.apple.com/guide/iphone/take-a-screenshot-or-screen-recording-iphc872c0115/ios

Take a screenshot and/or video of your macOS screen. Here is a guide: https://support.apple.com/guide/mac-help/take-screenshots-or-screen-recordings-mh26782/mac

30 thoughts on “Troubleshooting Cydia Impactor

    1. Hi Mathew,
      The versions for macOS and for iOS are different

      The zip file is for macOS and you can download it from here:
      https://iristech.co/iris/

      The .ipa file is for iOS installation and again you need to download it on your Macbook or PC but you upload it to your iPhone/iPad/iOS device via Cydia Impactor as shown here:
      https://iristech.co/iris-ios/

      I also did an updated tutorial for installation in 2019 πŸ™‚
      There were some changes like 2-factor authentication that were not present in 2018 and the tutorial on the page was outdated

  1. Hi,

    I am in great need of this on my IPad. Love this! My eyes have been hurting as well as other family members and we are glad to find it. Thank you so much. I am having an issue with an error Peer certificate can not be authenticated. Are you familiar with this one? http-win.cpp; line: 182 . I will try and research some more, just did not know if you get me there faster.

    Thanks so much,

    Alison

  2. Hi! First of all, I really like the app. Very convenient and helpful. Good job!
    Second of all, I got an error like shown in the “This happens when Apple Developer certificate is expired and you need to contact the developer” heading. I’ve tried deleting and revoking the ID with Cydia and it worked (the certificate’s gone). But then, I still get the same error message whenever I try to reinstall the app.

    1. Hi Bown,
      Glad you’re enjoying the app and sorry for the inconvenience
      That seems to be a recurring problem with Apple devices, perhaps try to contact Apple support to verify your certificate on their end so you don’t get the message anymore
      Keep us updated πŸ™‚

      Valentina
      Customer Communications Manager and Lead Marketing Specialist
      Iris Technologies Ltd.

    2. Hi Bown,
      Sorry for the unhelpful response

      I did an updated tutorial for installing Iris on your iOS device for 2019
      You can see it on the Iris for iOS page here:
      https://iristech.co/iris-ios/

      Or directly on YouTube here:
      https://youtu.be/EdoHN3zwqmc

      The videos on this page were for 2018 but Apple made some changes like forcing 2-factor authentication and app-specific passwords which complicate the process even more. We are working on improving the installation and reducing the steps to be more easy to install

      Daniel
      CEO Iris

  3. I’m getting the “failed to verify code signature….” error. Your note above says “This happens when Apple Developer certificate is expired and you need to contact the developer”, but I’m not sure what this means. Who is the Apple Developer and why do I need to contact them? Is there a way to get around this error so I can install IRIS?

    1. Hi Nicole,
      This is an issue with the Apple product. Try writing to their support staff or reinstalling the program
      Keep us updated πŸ™‚

      Valentina
      Customer Communications Manager and Lead Marketing Specialist
      Iris Technologies Ltd.

    2. Hi Nicole,
      Sorry for the unhelpful response

      I did an updated tutorial for installing Iris on your iOS device for 2019
      You can see it on the Iris for iOS page here:
      https://iristech.co/iris-ios/

      Or directly on YouTube here:
      https://youtu.be/EdoHN3zwqmc

      The videos on this page were for 2018 but Apple made some changes like forcing 2-factor authentication and app-specific passwords which complicate the process even more. We are working on improving the installation and reducing the steps to be more easy to install

      Daniel
      CEO Iris

  4. I have tried to install the Impactor program for my Ipad mini but even after following the troubleshooting video and deleting the requirement for a developer, I keep getting the following:

    The Network Extensions feature is only available to users enrolled in the Apple Developer Program.

    Then it says to enroll in the program. But I don’t want to be a developer. So how do I get around this error?

    Thank you. Susan Artz

    1. Hi Susan,
      Can you try downloading the Impactor on your PC and try installing Iris through the computer on your iPad?
      Follow this article for instructions:
      https://iristech.co/iris-ios/

      Valentina
      Customer Communications Manager and Lead Marketing Specialist
      Iris Technologies Ltd.

    2. Hi Susan,
      Sorry for the unhelpful response

      I did an updated tutorial for installing Iris on your iOS device for 2019
      You can see it on the Iris for iOS page here:
      https://iristech.co/iris-ios/

      Or directly on YouTube here:
      https://youtu.be/EdoHN3zwqmc

      The videos on this page were for 2018 but Apple made some changes like forcing 2-factor authentication and app-specific passwords which complicate the process even more. We are working on improving the installation and reducing the steps to be more easy to install

      Daniel
      CEO Iris

  5. Hello,

    I downloaded it onto my iphone, and allowed the phone to trust it. However, when I open Iris, it opens for 1 second then closes. Do you know what I can do to fix this? Thank you!

    1. Hi Bown,
      Sorry for the unhelpful response

      I did an updated tutorial for installing Iris on your iOS device for 2019
      You can see it on the Iris for iOS page here:
      https://iristech.co/iris-ios/

      Or directly on YouTube here:
      https://youtu.be/EdoHN3zwqmc

      The videos on this page were for 2018 but Apple made some changes like forcing 2-factor authentication and app-specific passwords which complicate the process even more. We are working on improving the installation and reducing the steps to be more easy to install

      Daniel
      CEO Iris

  6. Hi there, Im getting this error: file:lockdown.cpp; line 57 ; what
    LOCKDOWN_E_INVALID_CONF could you please help me out? πŸ™‚

  7. Hello,

    each time I’m trying to put in my login and password on my Mac computer, I’m getting this error “installer.cpp, line 71, what / _assert(!teams.empty())”. I checked all the possible websites and forums but it didn’t help me. Could you please tell me what I have to do?

    Thanks in advance

Leave a Reply

Your email address will not be published. Required fields are marked *